NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2015-6748 — jsoup

MEDIUMFix: jhy/jsoup#582

CVE-2015-6748 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.jsoup:jsoup. A fix is available for org.jsoup:jsoup — see the affected versions and patch details below.

Improper Neutralization of Input During Web Page Generation in Jsoup

Also known asGHSA-48rh-qgjr-xfj6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2015-6748.

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
1.54%1.93%2.32%2.71%2.0%2.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jsoup:jsoup

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in jsoup before 1.8.3.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jsoup:jsoup≥ 1.6.0&&< 1.8.31.8.3org.jsoup:jsoup:1.8.3

Affected Products

2 products · 2 configurations
OS
debian linuxdebian
1 version
8.0
Application
jsoupjsoup
≥ 1.6.0 && < 1.8.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jsoup:jsoup, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jsoup:jsoup to 1.8.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-6748 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat JBoss BPMS 6.2jsoupRHSA-2015:2560
Red Hat JBoss BRMS 6.2jsoupRHSA-2015:2559

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in jsoup before 1.8.3.
O3 Security · Impact-Aware SCA

Is CVE-2015-6748 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2015-6748: jsoup XSS — Fixed in 1.8.3