CVE-2021-36150 — admin
MEDIUMCVE-2021-36150 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in silverstripe/admin. A fix is available for silverstripe/admin — see the affected versions and patch details below.
Cross-site Scripting in SilverStripe Framework
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
silverstripe/adminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
SilverStripe Framework through 4.8.1 allows XSS.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/admin | ≥ 1.0.0&&< 1.8.1 | 1.8.1composer require silverstripe/admin:^1.8.1 |
Affected Products
silverstripesilverstripeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/admin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/admin to 1.8.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-36150 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2021-36150 in your dependencies?
Find it across Packagist, including transitive dependencies.