NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
LOW severity

Silverstripe admin XSS Vulnerability via WYSIWYG editorGHSA-779c-7w4p-2c4g

LOW

GHSA-779c-7w4p-2c4g is a low-severity (CVSS 3.8) vulnerability in silverstripe/admin. A fix is available for silverstripe/admin — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Dec 7, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘silverstripe/admin🐘silverstripe/admin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

It is possible for a bad actor with access to the CMS to make use of onmouseover or onmouseout attributes in the WYSIWYG editor to embed malicious javascript.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsilverstripe/admin≥ 1.0.3&&< 1.0.41.0.4composer require silverstripe/admin:^1.0.4
🐘Packagistsilverstripe/admin≥ 1.1.0&&< 1.1.11.1.1composer require silverstripe/admin:^1.1.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/admin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update silverstripe/admin to 1.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-779c-7w4p-2c4g is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

It is possible for a bad actor with access to the CMS to make use of onmouseover or onmouseout attributes in the WYSIWYG editor to embed malicious javascript.
O3 Security · Impact-Aware SCA

Is GHSA-779c-7w4p-2c4g in your dependencies?

Find it across Packagist, including transitive dependencies.

Silverstripe admin XSS Vulnerability via WYSIWYG editor