CVE-2021-23265 — craftercms
MEDIUMCVE-2021-23265 is a medium-severity (CVSS 4.3) Improper Privilege Management vulnerability in org.craftercms:craftercms. A fix is available for org.craftercms:craftercms — see the affected versions and patch details below.
Improper Privilege Management in craftercms
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.craftercms:craftercmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A logged-in and authenticated user with a Reviewer Role may lock a content item.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.craftercms:craftercms | ≥ 3.1.0&&< 3.1.18 | 3.1.18org.craftercms:craftercms:3.1.18 |
Affected Products
crafter cmscraftercmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.craftercms:craftercms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.craftercms:craftercms to 3.1.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-23265 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2021-23265 in your dependencies?
Find it across Maven, including transitive dependencies.