CVE-2022-40635 — craftercms
HIGHCVE-2022-40635 is a high-severity (CVSS 7.2) CWE-913 vulnerability in org.craftercms:craftercms. A fix is available for org.craftercms:craftercms — see the affected versions and patch details below.
CrafterCMS OS Command Injection vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.craftercms:craftercmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Improper Control of Dynamically-Managed Code Resources vulnerability in Crafter Studio of Crafter CMS allows authenticated developers to execute OS commands via Groovy Sandbox Bypass.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.craftercms:craftercms | ≥ 3.1.0&&< 3.1.23 | 3.1.23org.craftercms:craftercms:3.1.23 |
Affected Products
crafter cmscraftercmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.craftercms:craftercms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.craftercms:craftercms to 3.1.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-40635 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-40635 in your dependencies?
Find it across Maven, including transitive dependencies.