NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2021-22510 — hp-application-automation…

HIGHFix: jenkinsci/hpe-application-automation-tools-plugin@9fbd698

CVE-2021-22510 is a high-severity (CVSS 8.8) Cross-site Scripting (XSS) vulnerability in org.jenkins-ci.plugins:hp-application-automation-tools-plugin. A fix is available for org.jenkins-ci.plugins:hp-application-automation-tools-plugin — see the affected versions and patch details below.

Reflected XSS vulnerability in Jenkins Micro Focus Application Automation Tools Plugin

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.00%2.13%4.27%6.40%0.2%5.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:hp-application-automation-tools-plugin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Micro Focus Application Automation Tools Plugin 6.7 and earlier does not escape user input in a form validation response.

This results in a reflected cross-site scripting (XSS) vulnerability.

Micro Focus Application Automation Tools Plugin 6.8 escapes user input in the affected form validation response.

A security hardening since Jenkins 2.275 and LTS 2.263.2 prevents exploitation of this vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:hp-application-automation-tools-pluginall versions6.8org.jenkins-ci.plugins:hp-application-automation-tools-plugin:6.8

Affected Products

1 product · 1 configurations
Application
application automation toolsmicrofocus
≤ 6.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:hp-application-automation-tools-plugin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:hp-application-automation-tools-plugin to 6.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-22510 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Micro Focus Application Automation Tools Plugin 6.7 and earlier does not escape user input in a form validation response. This results in a reflected cross-site scripting (XSS) vulnerability. Micro Focus Application Automation Tools Plugin 6.8 escapes user input in the affected form validation response. A security hardening since Jenkins 2.275 and LTS 2.263.2 prevents exploitation of this vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2021-22510 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-22510: hp-application XSS — Fixed in 6.8