NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2021-22513 — hp-application-automation…

MEDIUMFix: jenkinsci/hpe-application-automation-tools-plugin@497a143

CVE-2021-22513 is a medium-severity (CVSS 4.3) CWE-862 vulnerability in org.jenkins-ci.plugins:hp-application-automation-tools-plugin. A fix is available for org.jenkins-ci.plugins:hp-application-automation-tools-plugin — see the affected versions and patch details below.

Missing permission checks in Micro Focus Application Automation Tools Plugin

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.15%1.73%0.1%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:hp-application-automation-tools-plugin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Micro Focus Application Automation Tools Plugin 6.7 and earlier does not perform permission checks in methods implementing form validation.

This allows attackers with Overall/Read permission to connect to attacker-specified URLs using attacker-specified username and password.

Additionally, these form validation methods do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability.

Micro Focus Application Automation Tools Plugin 6.8 requires POST requests and Overall/Administer permission for the affected form validation methods.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:hp-application-automation-tools-pluginall versions7.2.3-betaorg.jenkins-ci.plugins:hp-application-automation-tools-plugin:7.2.3-beta

Affected Products

1 product · 1 configurations
Application
application automation toolsmicrofocus
≤ 6.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:hp-application-automation-tools-plugin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:hp-application-automation-tools-plugin to 7.2.3-beta or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-22513 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Micro Focus Application Automation Tools Plugin 6.7 and earlier does not perform permission checks in methods implementing form validation. This allows attackers with Overall/Read permission to connect to attacker-specified URLs using attacker-specified username and password. Additionally, these form validation methods do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Micro Focus Application Automation Tools Plugin 6.8 requires POST requests and Overall/Administer permission for the affected form validation methods.
O3 Security · Impact-Aware SCA

Is CVE-2021-22513 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-22513: hp-application CSRF — Fixed in 7.2.3-beta