CVE-2021-21699 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.biouno:uno-choice. EPSS puts its 30-day exploitation probability at 88.5% (100th percentile). A fix is available for org.biouno:uno-choice — see the affected versions and patch details below.
Stored XSS vulnerability in Jenkins Active Choices Plugin
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.biouno:uno-choiceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jenkins Active Choices Plugin 2.5.6 and earlier does not escape the parameter name of reactive parameters and dynamic reference parameters.
This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.
Jenkins Active Choices Plugin 2.5.7 escapes references to parameter names.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.biouno:uno-choice | all versions | 2.5.7org.biouno:uno-choice:2.5.7 |
Affected Products
active choicesjenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.biouno:uno-choice, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.biouno:uno-choice to 2.5.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-21699 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2021-21699 in your dependencies?
Find it across Maven, including transitive dependencies.