NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2020-2290 — uno-choice

MEDIUMFix: jenkinsci/active-choices-plugin@15e3e01

CVE-2020-2290 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.biouno:uno-choice. A fix is available for org.biouno:uno-choice — see the affected versions and patch details below.

Stored XSS vulnerability in Jenkins Active Choices Plugin

Also known asGHSA-rjch-j5x9-fgph
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.94%1.40%0.2%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.biouno:uno-choice

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Active Choices Plugin 2.4 and earlier does not escape List and Map return values of sandboxed scripts for Reactive Reference Parameters.

This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.

This issue is caused by an incomplete fix for SECURITY-470.

Active Choices Plugin 2.5 escapes all legal return values of sandboxed scripts.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.biouno:uno-choiceall versions2.5org.biouno:uno-choice:2.5

Affected Products

1 product · 1 configurations
Application
active choicesjenkins
≤ 2.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.biouno:uno-choice, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.biouno:uno-choice to 2.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2290 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Jenkins Active Choices Plugin 2.4 and earlier does not escape `List` and `Map` return values of sandboxed scripts for Reactive Reference Parameters. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission. This issue is caused by an incomplete fix for [SECURITY-470](https://www.jenkins.io/security/advisory/2017-10-23/#persisted-cross-site-scripting-vulnerability-in-active-choices-plugin). Active Choices Plugin 2.5 escapes all legal return values of sandboxed scripts.
O3 Security · Impact-Aware SCA

Is CVE-2020-2290 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2290: uno-choice XSS — Fixed in 2.5