NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2020-8091 — cms

MEDIUMFix: TYPO3/typo3@482e2e9

CVE-2020-8091 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in typo3/cms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for typo3/cms — see the affected versions and patch details below.

Typo3 Cross-Site Scripting in Flash component (ELTS)

Also known asBIT-typo3-2020-8091GHSA-qvhv-pwww-53jj
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
0.62%8.78%16.9%25.1%20.5%5.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

svg.swf in TYPO3 6.2.0 to 6.2.38 ELTS and 7.0.0 to 7.1.0 could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack on a targeted system. This may be at a contrib/websvg/svg.swf pathname.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms≥ 7.0.0&&< 7.2.07.2.0composer require typo3/cms:^7.2.0
🐘Packagisttypo3/cms≥ 6.2.0&&< 6.2.396.2.39composer require typo3/cms:^6.2.39

Affected Products

1 product · 2 configurations
Application
typo3typo3
≥ 7.0.0 && ≤ 7.1.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms to 7.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-8091 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

svg.swf in TYPO3 6.2.0 to 6.2.38 ELTS and 7.0.0 to 7.1.0 could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack on a targeted system. This may be at a contrib/websvg/svg.swf pathname.
O3 Security · Impact-Aware SCA

Is CVE-2020-8091 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-8091: cms XSS — Fixed in 7.2.0