Typo3 Cross-Site Scripting in Flash component (ELTS)GHSA-qvhv-pwww-53jj
MEDIUMFix: TYPO3/typo3@482e2e9GHSA-qvhv-pwww-53jj is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in typo3/cms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for typo3/cms — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
svg.swf in TYPO3 6.2.0 to 6.2.38 ELTS and 7.0.0 to 7.1.0 could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack on a targeted system. This may be at a contrib/websvg/svg.swf pathname.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 7.0.0&&< 7.2.0 | 7.2.0composer require typo3/cms:^7.2.0 |
| 🐘Packagist | typo3/cms | ≥ 6.2.0&&< 6.2.39 | 6.2.39composer require typo3/cms:^6.2.39 |
Affected Products
typo3typo3Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 7.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qvhv-pwww-53jj is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-qvhv-pwww-53jj in your dependencies?
Find it across Packagist, including transitive dependencies.