NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2020-7768 — grpc

CRITICALFix: grpc/grpc-node#1605

CVE-2020-7768 is a critical-severity (CVSS 9.8) CWE-1321 vulnerability in grpc. A fix is available for grpc — see the affected versions and patch details below.

Prototype pollution in grpc and @grpc/grpc-js

Also known asGHSA-pp75-xfpw-37g9
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.46%1.99%3.52%5.05%1.3%4.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.

grpcnpm
105Kdownloads / week
@grpc/grpc-jsnpm
83.5Mdownloads / week

Description

"The package grpc before 1.24.4 and the package @grpc/grpc-js before 1.1.8 are vulnerable to Prototype Pollution via loadPackageDefinition."

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmgrpcall versions1.24.4npm install grpc@1.24.4
📦npm@grpc/grpc-jsall versions1.1.8npm install @grpc/grpc-js@1.1.8

Affected Products

1 product · 2 configurations
Application
grpcgrpc
< 1.24.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for grpc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update grpc to 1.24.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-7768 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

"The package grpc before 1.24.4 and the package @grpc/grpc-js before 1.1.8 are vulnerable to Prototype Pollution via loadPackageDefinition."
O3 Security · Impact-Aware SCA

Is CVE-2020-7768 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-7768: grpc — Fixed in 1.24.4