CVE-2024-37168 is a medium-severity (CVSS 5.3) CWE-789 vulnerability in @grpc/grpc-js. A fix is available for @grpc/grpc-js — see the affected versions and patch details below.
@grpc/grpc-js can allocate memory for incoming messages well above configured limits
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-37168.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@grpc/grpc-jsnpmDescription
@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to versions 1.10.9, 1.9.15, and 1.8.22, there are two separate code paths in which memory can be allocated per message in excess of the grpc.max_receive_message_length channel option: If an incoming message has a size on the wire greater than the configured limit, the entire message is buffered before it is discarded; and/or if an incoming message has a size within the limit on the wire but decompresses to a size greater than the limit, the entire message is decompressed into memory, and on the server is not discarded. This has been patched in versions 1.10.9, 1.9.15, and 1.8.22.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @grpc/grpc-js | ≥ 1.10.0&&< 1.10.9 | 1.10.9npm install @grpc/grpc-js@1.10.9 |
| 📦npm | @grpc/grpc-js | ≥ 1.9.0&&< 1.9.15 | 1.9.15npm install @grpc/grpc-js@1.9.15 |
| 📦npm | @grpc/grpc-js | all versions | 1.8.22npm install @grpc/grpc-js@1.8.22 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @grpc/grpc-js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @grpc/grpc-js to 1.10.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-37168 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-37168 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2024-37168 in your dependencies?
Find it across npm, including transitive dependencies.