NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2020-7719 — locutus

CRITICALFix: kvz/locutus#418

CVE-2020-7719 is a critical-severity (CVSS 9.8) CWE-1321 vulnerability in locutus. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for locutus — see the affected versions and patch details below.

Prototype Pollution in locutus

Also known asGHSA-f98m-q3hr-p5wqSNYK-JS-LOCUTUS-598675
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
1.22%1.90%2.57%3.25%1.7%2.8%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

138other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
locutusnpm
789Kdownloads / week

Description

All versions of package locutus prior to version 2.0.12 are vulnerable to Prototype Pollution via the php.strings.parse_str function.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmlocutusall versions2.0.12npm install locutus@2.0.12

Affected Products

1 product · 1 configurations
Application
locutuslocutus
< 2.0.12
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for locutus, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update locutus to 2.0.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-7719 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

All versions of package locutus prior to version 2.0.12 are vulnerable to Prototype Pollution via the php.strings.parse_str function.
O3 Security · Impact-Aware SCA

Is CVE-2020-7719 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-7719: locutus — Fixed in 2.0.12