NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2021-23392 — locutus

HIGHFix: locutusjs/locutus@eb86332

CVE-2021-23392 is a high-severity (CVSS 7.5) vulnerability in locutus. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for locutus — see the affected versions and patch details below.

Uncontrolled Resource Consumption in locutus

Also known asGHSA-39q4-p535-c852SNYK-JS-LOCUTUS-1090597
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.81%1.62%2.44%0.4%1.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

138other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
locutusnpm
499Kdownloads / week

Description

The package locutus before 2.0.15 are vulnerable to Regular Expression Denial of Service (ReDoS) via the gopher_parsedir function.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmlocutusall versions2.0.15npm install locutus@2.0.15

Affected Products

1 product · 1 configurations
Application
locutuslocutus
< 2.0.15
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for locutus, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update locutus to 2.0.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-23392 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The package locutus before 2.0.15 are vulnerable to Regular Expression Denial of Service (ReDoS) via the gopher_parsedir function.
O3 Security · Impact-Aware SCA

Is CVE-2021-23392 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2021-23392: locutus DoS — Fixed in 2.0.15