CVE-2020-5263 is a medium-severity (CVSS 4.9) CWE-522 vulnerability in auth0-js. A fix is available for auth0-js — see the affected versions and patch details below.
Information disclosure through error object in auth0.js
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
auth0-jsnpmDescription
Overview
Between versions 8.0.0 and 9.13.1(inclusive), in the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered.
If the error object is exposed or logged without modification, the application risks password exposure.
Am I affected?
You are affected by this vulnerability if all of the following conditions apply:
- You are using Auth0.js version between 8.0.0 and 9.13.1(inclusive).
- You store or display error objects without filtering.
How to fix that?
Developers should upgrade auth0.js to version 9.13.2 or later where user inputted passwords are masked in errors. If upgrading is not possible, a temporary fix may include not storing the error object or displaying it publicly without modification.
Will this update impact my users?
This fix patches the Auth0.js and may require changes in application code due to password no longer available in error object, but it will not impact your users, their current state, or any existing sessions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | auth0-js | ≥ 8.0.0&&< 9.13.2 | 9.13.2npm install auth0-js@9.13.2 |
Affected Products
auth0.jsauth0Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for auth0-js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update auth0-js to 9.13.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-5263 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2020-5263 in your dependencies?
Find it across npm, including transitive dependencies.