NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2018-7307 — auth0-js

HIGH

CVE-2018-7307 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in auth0-js. A fix is available for auth0-js — see the affected versions and patch details below.

Auth0-js bypasses CSRF checks

Also known asGHSA-wpq7-q8j4-72jg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs43th percentile — riskier than 43% of all scored CVEsHighest risk
0.00%0.34%0.68%1.02%0.2%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

416other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
auth0-jsnpm
149Kdownloads / week

Description

The Auth0.js library has a vulnerability affecting versions below 9.3 that allows an attacker to bypass the CSRF check from the state parameter if it's missing from the authorization response, leaving the client vulnerable to CSRF attacks.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmauth0-jsall versions9.3.0npm install auth0-js@9.3.0

Affected Products

1 product · 1 configurations
Application
auth0.jsauth0
< 9.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for auth0-js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update auth0-js to 9.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-7307 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The Auth0.js library has a vulnerability affecting versions below 9.3 that allows an attacker to bypass the CSRF check from the state parameter if it's missing from the authorization response, leaving the client vulnerable to CSRF attacks.
O3 Security · Impact-Aware SCA

Is CVE-2018-7307 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2018-7307: auth0-js CSRF — Fixed in 9.3.0