NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2017-17068 — auth0-js

HIGH

CVE-2017-17068 is a high-severity (CVSS 7.5) Information Exposure vulnerability in auth0-js. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for auth0-js — see the affected versions and patch details below.

auth0-js Privilege Escalation Vulnerability

Also known asGHSA-3rpr-mg43-xhq4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.00%0.64%1.28%1.92%0.3%1.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

416other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
auth0-jsnpm
149Kdownloads / week

Description

A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions < 8.12. This vulnerability allows an attacker to acquire authenticated users' tokens and invoke services on a user's behalf if the target site or application uses a popup callback page with auth0.popup.callback().

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmauth0-jsall versions8.12.0npm install auth0-js@8.12.0

Affected Products

1 product · 1 configurations
Application
auth0.jsauth0
< 8.12
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for auth0-js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update auth0-js to 8.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-17068 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions < 8.12. This vulnerability allows an attacker to acquire authenticated users' tokens and invoke services on a user's behalf if the target site or application uses a popup callback page with auth0.popup.callback().
O3 Security · Impact-Aware SCA

Is CVE-2017-17068 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2017-17068: auth0-js — Fixed in 8.12.0