NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2020-28446 — ntesseract

CRITICALFix: taoyuan/ntesseract@fcbc36f

CVE-2020-28446 is a critical-severity (CVSS 9.8) CWE-77 vulnerability in ntesseract. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for ntesseract — see the affected versions and patch details below.

ntesseract vulnerable to Command Injection

Also known asGHSA-w868-4576-rv24
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.5%probability of exploitation in next 30 days
Lower Risk+0.10%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.92%5.31%9.71%14.1%11.6%3.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ntesseractnpm
22downloads / week

Description

The package ntesseract before 0.2.9 are vulnerable to Command Injection via lib/tesseract.js.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmntesseractall versions0.2.9npm install ntesseract@0.2.9

Affected Products

1 product · 1 configurations
Application
ntesseractntesseract_project
< 0.2.9
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ntesseract, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ntesseract to 0.2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-28446 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

The package ntesseract before 0.2.9 are vulnerable to Command Injection via lib/tesseract.js.
O3 Security · Impact-Aware SCA

Is CVE-2020-28446 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-28446: ntesseract — Fixed in 0.2.9