NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2020-2281 — lockable-resources

MEDIUMFix: jenkinsci/lockable-resources-plugin@50ab824

CVE-2020-2281 is a medium-severity (CVSS 5.4) Cross-Site Request Forgery (CSRF) vulnerability in org.6wind.jenkins:lockable-resources. A fix is available for org.6wind.jenkins:lockable-resources — see the affected versions and patch details below.

CSRF vulnerability in Jenkins Lockable Resources Plugin

Also known asGHSA-rvww-w62m-hch8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.78%1.17%0.1%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.6wind.jenkins:lockable-resources

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Lockable Resources Plugin 2.8 and earlier does not require POST requests for several HTTP endpoints, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to reserve, unreserve, unlock, and reset resources. Lockable Resources Plugin 2.9 requires POST requests for the affected HTTP endpoints.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.6wind.jenkins:lockable-resourcesall versions2.9org.6wind.jenkins:lockable-resources:2.9

Affected Products

1 product · 1 configurations
Application
lockable resourcesjenkins
≤ 2.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.6wind.jenkins:lockable-resources, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.6wind.jenkins:lockable-resources to 2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2281 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Lockable Resources Plugin 2.8 and earlier does not require POST requests for several HTTP endpoints, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to reserve, unreserve, unlock, and reset resources. Lockable Resources Plugin 2.9 requires POST requests for the affected HTTP endpoints.
O3 Security · Impact-Aware SCA

Is CVE-2020-2281 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2281: lockable-resources CSRF — Fixed in 2.9