NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-1003042 — lockable-resources

MEDIUMFix: jenkinsci/lockable-resources-plugin@4f401e2

CVE-2019-1003042 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.6wind.jenkins:lockable-resources. A fix is available for org.6wind.jenkins:lockable-resources — see the affected versions and patch details below.

Jenkins Lockable Resources Plugin XSS vulnerability

Also known asGHSA-wqjj-c9cx-q7cf
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.00%0.63%1.26%1.90%0.1%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.6wind.jenkins:lockable-resources

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A cross site scripting vulnerability in Jenkins Lockable Resources Plugin 2.4 and earlier allows attackers able to control resource names to inject arbitrary JavaScript in web pages rendered by the plugin.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.6wind.jenkins:lockable-resourcesall versions2.5org.6wind.jenkins:lockable-resources:2.5

Affected Products

1 product · 1 configurations
Application
lockable resourcesjenkins
≤ 2.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.6wind.jenkins:lockable-resources, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.6wind.jenkins:lockable-resources to 2.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-1003042 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11jenkins-2-plugins-0:3.11.1553788831-1.el7RHSA-2019:1423

Frequently Asked Questions

A cross site scripting vulnerability in Jenkins Lockable Resources Plugin 2.4 and earlier allows attackers able to control resource names to inject arbitrary JavaScript in web pages rendered by the plugin.
O3 Security · Impact-Aware SCA

Is CVE-2019-1003042 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-1003042: lockable-resources XSS — Fixed in 2.5