NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2020-2204 — fortify-on-demand-uploader

MEDIUMFix: jenkinsci/fortify-on-demand-uploader-plugin@006c233

CVE-2020-2204 is a medium-severity (CVSS 5.4) CWE-862 vulnerability in org.jenkins-ci.plugins:fortify-on-demand-uploader. A fix is available for org.jenkins-ci.plugins:fortify-on-demand-uploader — see the affected versions and patch details below.

Missing permission checks in Jenkins Fortify on Demand Plugin

Also known asGHSA-fhmf-xf2q-4m8p
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.37%0.75%1.12%0.0%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:fortify-on-demand-uploader

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A missing permission check in Jenkins Fortify on Demand Plugin 5.0.1 and earlier allows attackers with Overall/Read permission to connect to the globally configured Fortify on Demand endpoint using attacker-specified credentials IDs.

This form validation method requires appropriate permission in Fortify on Demand Plugin 6.0.1.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:fortify-on-demand-uploaderall versions6.0.1org.jenkins-ci.plugins:fortify-on-demand-uploader:6.0.1

Affected Products

1 product · 1 configurations
Application
fortify on demandjenkins
≤ 5.0.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:fortify-on-demand-uploader, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:fortify-on-demand-uploader to 6.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2204 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

A missing permission check in Jenkins Fortify on Demand Plugin 5.0.1 and earlier allows attackers with Overall/Read permission to connect to the globally configured Fortify on Demand endpoint using attacker-specified credentials IDs. This form validation method requires appropriate permission in Fortify on Demand Plugin 6.0.1.
O3 Security · Impact-Aware SCA

Is CVE-2020-2204 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2204: fortify-on-demand — Fixed in 6.0.1