NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2019-10449 — fortify-on-demand-uploader

HIGHFix: jenkinsci/fortify-on-demand-uploader-plugin@2776420

CVE-2019-10449 is a high-severity (CVSS 8.8) CWE-312 vulnerability in org.jenkins-ci.plugins:fortify-on-demand-uploader. A fix is available for org.jenkins-ci.plugins:fortify-on-demand-uploader — see the affected versions and patch details below.

Jenkins Fortify on Demand Plugin stores credentials in plain text

Also known asGHSA-hhhh-69qp-5p2v
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk+0.17%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.90%1.35%0.1%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:fortify-on-demand-uploader

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Fortify on Demand Plugin stores credentials unencrypted in job config.xml files on the Jenkins controller. These credentials can be viewed by users with Extended Read permission or access to the Jenkins controller file system.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:fortify-on-demand-uploaderall versions5.0.0org.jenkins-ci.plugins:fortify-on-demand-uploader:5.0.0

Affected Products

1 product · 1 configurations
Application
fortify on demandjenkins
≤ 4.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:fortify-on-demand-uploader, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:fortify-on-demand-uploader to 5.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10449 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Jenkins Fortify on Demand Plugin stores credentials unencrypted in job `config.xml` files on the Jenkins controller. These credentials can be viewed by users with Extended Read permission or access to the Jenkins controller file system.
O3 Security · Impact-Aware SCA

Is CVE-2019-10449 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-10449: fortify-on-demand — Fixed in 5.0.0