NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2020-2203 — fortify-on-demand-uploader

MEDIUMFix: jenkinsci/fortify-on-demand-uploader-plugin@28932f7

CVE-2020-2203 is a medium-severity (CVSS 4.3) Cross-Site Request Forgery (CSRF) vulnerability in org.jenkins-ci.plugins:fortify-on-demand-uploader. A fix is available for org.jenkins-ci.plugins:fortify-on-demand-uploader — see the affected versions and patch details below.

CSRF vulnerability in Jenkins Fortify on Demand Plugin

Also known asGHSA-p364-xfp2-f9rr
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.03%0.41%0.79%1.17%0.5%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:fortify-on-demand-uploader

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A cross-site request forgery vulnerability in Jenkins Fortify on Demand Plugin 5.0.1 and earlier allows attackers to connect to the globally configured Fortify on Demand endpoint using attacker-specified credentials IDs.

This form validation method requires appropriate permission in Fortify on Demand Plugin 6.0.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:fortify-on-demand-uploaderall versions6.0.0org.jenkins-ci.plugins:fortify-on-demand-uploader:6.0.0

Affected Products

1 product · 1 configurations
Application
fortify on demandjenkins
≤ 5.0.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:fortify-on-demand-uploader, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:fortify-on-demand-uploader to 6.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2203 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A cross-site request forgery vulnerability in Jenkins Fortify on Demand Plugin 5.0.1 and earlier allows attackers to connect to the globally configured Fortify on Demand endpoint using attacker-specified credentials IDs. This form validation method requires appropriate permission in Fortify on Demand Plugin 6.0.0.
O3 Security · Impact-Aware SCA

Is CVE-2020-2203 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2203: fortify-on-demand CSRF — Fixed in 6.0.0