NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2020-2109 — workflow-cps

HIGHFix: jenkinsci/workflow-cps-plugin@41cb4e0

CVE-2020-2109 is a high-severity (CVSS 8.8) Improper Input Validation vulnerability in org.jenkins-ci.plugins.workflow:workflow-cps. A fix is available for org.jenkins-ci.plugins.workflow:workflow-cps — see the affected versions and patch details below.

Improper Input Validation in Jenkins Pipeline: Groovy Plugin

Also known asGHSA-99mf-f3qh-wqrp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk-0.01%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.59%1.18%1.77%0.5%1.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins.workflow:workflow-cps

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Sandbox protection in Jenkins Pipeline: Groovy Plugin 2.78 and earlier can be circumvented through default parameter expressions in CPS-transformed methods.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins.workflow:workflow-cpsall versions2.79org.jenkins-ci.plugins.workflow:workflow-cps:2.79

Affected Products

1 product · 1 configurations
Application
pipeline\jenkins
≤ 2.78
1 version
_groovy

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins.workflow:workflow-cps, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins.workflow:workflow-cps to 2.79 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2109 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11jenkins-2-plugins-0:3.11.1591354111-1.el7RHSA-2020:2478
Red Hat OpenShift Container Platform 4.3jenkins-2-plugins-0:4.3.1597915133-1.el7RHSA-2020:3616
Red Hat OpenShift Container Platform 4.4jenkins-2-plugins-0:4.4.1592817009-1.el7RHSA-2020:2737
Red Hat OpenShift Container Platform 4.5openshift4/ose-aws-machine-controllers:v4.5.0-202007012112.p0RHBA-2020:2409

Frequently Asked Questions

Sandbox protection in Jenkins Pipeline: Groovy Plugin 2.78 and earlier can be circumvented through default parameter expressions in CPS-transformed methods.
O3 Security · Impact-Aware SCA

Is CVE-2020-2109 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2109: workflow-cps — Fixed in 2.79