NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2017-1000096 — workflow-cps

HIGH

CVE-2017-1000096 is a high-severity (CVSS 8.8) CWE-732 vulnerability in org.jenkins-ci.plugins.workflow:workflow-cps. A fix is available for org.jenkins-ci.plugins.workflow:workflow-cps — see the affected versions and patch details below.

Arbitrary code execution due to incomplete sandbox protection in Jenkins Pipeline

Also known asGHSA-mhwq-4mh7-fv7c
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.00%0.70%1.41%2.11%0.2%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins.workflow:workflow-cps

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Arbitrary code execution due to incomplete sandbox protection: Constructors, instance variable initializers, and instance initializers in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins.workflow:workflow-cpsall versions2.36.1org.jenkins-ci.plugins.workflow:workflow-cps:2.36.1

Affected Products

1 product · 1 configurations
Application
pipeline\jenkins
≤ 2.36
1 version
_groovy

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins.workflow:workflow-cps, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins.workflow:workflow-cps to 2.36.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000096 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This issue affects the versions of jenkins-plugin-workflow-cps as shipped with Red Hat OpenShift Enterprise 3. However, this flaw is of low impact under the supported scenarios in OpenShift Enterprise 3. A future update may address this issue.

ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.6atomic-openshift-0:3.6.173.0.21-1.git.0.f95b0e7.el7RHBA-2017:2642

Frequently Asked Questions

Arbitrary code execution due to incomplete sandbox protection: Constructors, instance variable initializers, and instance initializers in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.
O3 Security · Impact-Aware SCA

Is CVE-2017-1000096 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-1000096: workflow-cps RCE — Fixed in 2.36.1