NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2020-15112 — etcd

MEDIUMFix: etcd-io/etcd#11793

CVE-2020-15112 is a medium-severity (CVSS 6.5) Improper Input Validation vulnerability in go.etcd.io/etcd/v3. A fix is available for go.etcd.io/etcd/v3 — see the affected versions and patch details below.

etcd's WAL `ReadAll` method vulnerable to an entry with large index causing panic

Also known asBIT-etcd-2020-15106BIT-etcd-2020-15112CVE-2020-15106GHSA-m332-53r6-2w93GHSA-p4g4-wgrh-qrg2GO-2020-0005
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.59%1.17%1.76%0.1%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹go.etcd.io/etcd/v3🐹go.etcd.io/etcd/v3

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Vulnerability type

Data Validation

Detail

In the ReadAll method in wal/wal.go, it is possible to have an entry index greater then the number of entries. This could cause issues when WAL entries are being read during consensus as an arbitrary etcd consensus participant could go down from a runtime panic when reading the entry.

References

Find out more on this vulnerability in the security audit report

For more information

If you have any questions or comments about this advisory:

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogo.etcd.io/etcd/v3all versions3.3.23go get go.etcd.io/etcd/v3@v3.3.23
🐹Gogo.etcd.io/etcd/v3≥ 3.4.0&&< 3.4.103.4.10go get go.etcd.io/etcd/v3@v3.4.10

Affected Products

2 products · 3 configurations
Application
etcdetcd
≥ 3.4.0 && < 3.4.10
range
OS
fedorafedoraproject
1 version
32

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for go.etcd.io/etcd/v3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update go.etcd.io/etcd/v3 to 3.3.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-15112 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

In Red Hat OpenShift Container Platform (RHOCP), the affected components are behind OpenShift OAuth authentication. This restricts access to the vulnerable etcd to authenticated users only, therefore the impact of this vulnerability is Low. A similar access restriction is in place in Red Hat OpenStack Platform (RHOSP)…

ProductFixed inAdvisory
Red Hat Enterprise Linux 7 Extrasetcd-0:3.2.32-1.el7_9RHSA-2021:1407
Red Hat OpenShift Container Platform 4.8openshift4/ose-etcd:v4.8.0-202106152230.p0.git.aefa6bf.assembly.streamRHSA-2021:2438
Red Hat OpenStack Platform 16.1etcd-0:3.3.23-1.el8ostRHSA-2021:0916

Frequently Asked Questions

### Vulnerability type Data Validation ### Detail In the ReadAll method in wal/wal.go, it is possible to have an entry index greater then the number of entries. This could cause issues when WAL entries are being read during consensus as an arbitrary etcd consensus participant could go down from a runtime panic when reading the entry. ### References Find out more on this vulnerability in the [security audit report](https://github.com/etcd-io/etcd/blob/master/security/SECURITY_AUDIT.pdf) ### For more information If you have any questions or comments about this advisory: * Contact the [etcd se
O3 Security · Impact-Aware SCA

Is CVE-2020-15112 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2020-15112: etcd — Fixed in 3.3.23