Etcd auth Inaccurate logging of authentication attempts for users with CN-based auth onlyGHSA-vjg6-93fv-qv64
GHSA-vjg6-93fv-qv64 is a security vulnerability in go.etcd.io/etcd/v3. A fix is available for go.etcd.io/etcd/v3 — see the affected versions and patch details below.
Real-World Exposure
go.etcd.io/etcd/v3🐹go.etcd.io/etcd/v3Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Vulnerability type
Logging
Detail
etcd users who have no password can authenticate only through a client certificate. When such users try to authenticate into etcd using the Authenticate endpoint, errors are logged with insufficient information regarding why the authentication failed, and may be misleading when auditing etcd logs.
References
Find out more on this vulnerability in the security audit report
For more information
If you have any questions or comments about this advisory:
- Contact the etcd security committee
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | go.etcd.io/etcd/v3 | ≥ 3.4.0-rc.0&&< 3.4.10 | 3.4.10go get go.etcd.io/etcd/v3@v3.4.10 |
| 🐹Go | go.etcd.io/etcd/v3 | all versions | 3.3.23go get go.etcd.io/etcd/v3@v3.3.23 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for go.etcd.io/etcd/v3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update go.etcd.io/etcd/v3 to 3.4.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vjg6-93fv-qv64 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-vjg6-93fv-qv64 in your dependencies?
Find it across Go, including transitive dependencies.