NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2020-12689 — keystone

HIGHFix: openstack/keystone@37e9907

CVE-2020-12689 is a high-severity (CVSS 8.8) Improper Privilege Management vulnerability in keystone. A fix is available for keystone — see the affected versions and patch details below.

OpenStack Keystone EC2 and/or credential endpoints are not protected from a scoped context

Also known asGHSA-chgw-36xv-47cwPYSEC-2020-53
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.57%1.06%1.56%2.06%1.1%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍keystone🐍keystone

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in OpenStack Keystone before 15.0.1, and 16.0.0. Any user authenticated within a limited scope (trust/oauth/application credential) can create an EC2 credential with an escalated permission, such as obtaining admin while the user is on a limited viewer role. This potentially allows a malicious user to act as the admin on a project another user has the admin role on, which can effectively grant that user global admin privileges.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIkeystoneall versions15.0.1pip install --upgrade 'keystone==15.0.1'
🐍PyPIkeystone≥ 16.0.0&&< 16.0.116.0.1pip install --upgrade 'keystone==16.0.1'

Affected Products

2 products · 3 configurations
OS
ubuntu linuxcanonical
1 version
18.04
Application
keystoneopenstack
< 15.0.1
1 version
16.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keystone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update keystone to 15.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-12689 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Red Hat Quay includes keystone-client, which is not vulnerable to this (server-side) vulnerability.

ProductFixed inAdvisory
Red Hat OpenStack Platform 10.0 (Newton)openstack-keystone-1:10.0.3-8.el7ostRHSA-2020:3096
Red Hat OpenStack Platform 13.0 (Queens)openstack-keystone-1:13.0.4-3.el7ostRHSA-2020:2732
Red Hat OpenStack Platform 15.0 (Stein)openstack-keystone-1:15.0.1-0.20200512110437.95b2bbe.el8ostRHSA-2020:3102
Red Hat OpenStack Platform 16.0 (Train)openstack-keystone-1:16.0.1-0.20200511063421.40cbb7b.el8ostRHSA-2020:3105

Frequently Asked Questions

An issue was discovered in OpenStack Keystone before 15.0.1, and 16.0.0. Any user authenticated within a limited scope (trust/oauth/application credential) can create an EC2 credential with an escalated permission, such as obtaining admin while the user is on a limited viewer role. This potentially allows a malicious user to act as the admin on a project another user has the admin role on, which can effectively grant that user global admin privileges.
O3 Security · Impact-Aware SCA

Is CVE-2020-12689 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2020-12689: keystone — Fixed in 15.0.1