NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2019-7722 — pmd-core

HIGH

CVE-2019-7722 is a high-severity (CVSS 8.1) XML External Entity (XXE) vulnerability in net.sourceforge.pmd:pmd-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for net.sourceforge.pmd:pmd-core — see the affected versions and patch details below.

Improper Restriction of XML External Entity Reference in PMD

Also known asGHSA-57qj-79gh-69w8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.16%1.73%0.5%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕net.sourceforge.pmd:pmd-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

PMD 5.8.1 and earlier processes XML external entities in ruleset files it parses as part of the analysis process, allowing attackers tampering it (either by direct modification or MITM attacks when using remote rulesets) to perform information disclosure, denial of service, or request forgery attacks. (PMD 6.x is unaffected because of a 2017-09-15 change.)

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavennet.sourceforge.pmd:pmd-coreall versions6.0.0net.sourceforge.pmd:pmd-core:6.0.0

Affected Products

1 product · 1 configurations
Application
pmdpmd_project
≤ 5.8.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for net.sourceforge.pmd:pmd-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update net.sourceforge.pmd:pmd-core to 6.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-7722 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

PMD 5.8.1 and earlier processes XML external entities in ruleset files it parses as part of the analysis process, allowing attackers tampering it (either by direct modification or MITM attacks when using remote rulesets) to perform information disclosure, denial of service, or request forgery attacks. (PMD 6.x is unaffected because of a 2017-09-15 change.)
O3 Security · Impact-Aware SCA

Is CVE-2019-7722 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-7722: pmd-core DoS — Fixed in 6.0.0