CVE-2019-7537 is a critical-severity (CVSS 9.8) CWE-77 vulnerability in donfig. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for donfig — see the affected versions and patch details below.
Donfig Command Injection in collect_yaml method
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
donfigReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Donfig 0.3.0. There is a vulnerability in the collect_yaml method in config_obj.py. It can execute arbitrary Python commands, resulting in command execution.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | donfig | all versions | 0.4.0pip install --upgrade 'donfig==0.4.0' |
Affected Products
donfigpytrollResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for donfig, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update donfig to 0.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-7537 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2019-7537 in your dependencies?
Find it across PyPI, including transitive dependencies.