NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-6799 — phpmyadmin

MEDIUM

CVE-2019-6799 is a medium-severity (CVSS 5.9) vulnerability in phpmyadmin/phpmyadmin. EPSS puts its 30-day exploitation probability at 14.8% (97th percentile). A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin Arbitrary file read vulnerability

Also known asGHSA-c8wj-q36q-3wg4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
14.8%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
0.00%31.9%63.7%95.6%76.6%14.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in phpMyAdmin before 4.8.5. When the AllowArbitraryServer configuration setting is set to true, with the use of a rogue MySQL server, an attacker can read any file on the server that the web server's user can access. This is related to the mysql.allow_local_infile PHP configuration, and the inadvertent ignoring of "options(MYSQLI_OPT_LOCAL_INFILE" calls.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 4.8&&< 4.8.54.8.5composer require phpmyadmin/phpmyadmin:^4.8.5

Affected Products

2 products · 2 configurations
OS
debian linuxdebian
1 version
8.0
Application
phpmyadminphpmyadmin
≥ 4.0.0 && ≤ 4.8.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 4.8.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-6799 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect CVE-2019-6799

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2019-6799 -u https://target
Template
phpMyAdmin <4.8.5 - Local File Inclusion
Severity
medium
Impact
Successful exploitation of this vulnerability can lead to unauthorized access to sensitive files.
Remediation
Upgrade phpMyAdmin to version 4.8.5 or later to mitigate this vulnerability.

Template by ProjectDiscovery nuclei-templates (pwnhxl), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

An issue was discovered in phpMyAdmin before 4.8.5. When the AllowArbitraryServer configuration setting is set to true, with the use of a rogue MySQL server, an attacker can read any file on the server that the web server's user can access. This is related to the mysql.allow_local_infile PHP configuration, and the inadvertent ignoring of "options(MYSQLI_OPT_LOCAL_INFILE" calls.
O3 Security · Impact-Aware SCA

Is CVE-2019-6799 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-6799: phpmyadmin — Fixed in 4.8.5