NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-5884 — elfinder

MEDIUMFix: Studio-42/elFinder@f133163

CVE-2019-5884 is a medium-severity (CVSS 5.9) Information Exposure vulnerability in studio-42/elfinder. A fix is available for studio-42/elfinder — see the affected versions and patch details below.

Sensitive Data Exposure in elFinder

Also known asGHSA-jcgc-vxqg-85xx
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 25, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.59%1.18%1.77%0.3%1.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘studio-42/elfinder

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

php/elFinder.class.php in elFinder before 2.1.45 leaks information if PHP's curl extension is enabled and safe_mode or open_basedir is not set.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagiststudio-42/elfinderall versions2.1.45composer require studio-42/elfinder:^2.1.45

Affected Products

1 product · 1 configurations
Application
elfinderstd42
< 2.1.45
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for studio-42/elfinder, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update studio-42/elfinder to 2.1.45 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-5884 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

php/elFinder.class.php in elFinder before 2.1.45 leaks information if PHP's curl extension is enabled and safe_mode or open_basedir is not set.
O3 Security · Impact-Aware SCA

Is CVE-2019-5884 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-5884: elfinder Info Disclosure — Fixed in 2.1.45