CVE-2019-20526 — parent
MEDIUMCVE-2019-20526 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.igniterealtime.openfire:parent. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.igniterealtime.openfire:parent — see the affected versions and patch details below.
Ignite Realtime Openfire allows Cross-site Scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.igniterealtime.openfire:parentReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Ignite Realtime Openfire 4.4.1 allows XSS via the setup/setup-datasource-standard.jsp password parameter. This issue was fixed in version 4.4.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.igniterealtime.openfire:parent | all versions | 4.4.2org.igniterealtime.openfire:parent:4.4.2 |
Affected Products
openfireigniterealtimeResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.igniterealtime.openfire:parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.igniterealtime.openfire:parent to 4.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-20526 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2019-20526 in your dependencies?
Find it across Maven, including transitive dependencies.