NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-11688 — parent

MEDIUMFix: igniterealtime/Openfire@ed3492a

CVE-2018-11688 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.igniterealtime.openfire:parent. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.igniterealtime.openfire:parent — see the affected versions and patch details below.

Ignite Realtime Openfire vulnerable to cross-site scripting

Also known asGHSA-jphj-5g3m-w7x6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
1.87%2.32%2.77%3.22%2.7%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.igniterealtime.openfire:parent

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Ignite Realtime Openfire before 3.9.2 is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability via a crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.igniterealtime.openfire:parentall versions3.9.2org.igniterealtime.openfire:parent:3.9.2

Affected Products

1 product · 1 configurations
Application
openfireigniterealtime
1 version
3.7.1
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.igniterealtime.openfire:parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.igniterealtime.openfire:parent to 3.9.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-11688 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Ignite Realtime Openfire before 3.9.2 is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability via a crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.
O3 Security · Impact-Aware SCA

Is CVE-2018-11688 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-11688: parent XSS — Fixed in 3.9.2