NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-20366 — parent

MEDIUMFix: igniterealtime/Openfire#1561

CVE-2019-20366 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.igniterealtime.openfire:parent. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.igniterealtime.openfire:parent — see the affected versions and patch details below.

XSS in Ignite Realtime Openfire via isTrustStore

Also known asGHSA-m6pr-xcrm-4qqp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.77%1.23%1.70%2.16%1.7%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.igniterealtime.openfire:parent

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An XSS issue was discovered in Ignite Realtime Openfire 4.4.4 via isTrustStore to Manage Store Contents.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.igniterealtime.openfire:parentall versions4.5.0org.igniterealtime.openfire:parent:4.5.0

Affected Products

1 product · 1 configurations
Application
openfireigniterealtime
1 version
4.4.4
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.igniterealtime.openfire:parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.igniterealtime.openfire:parent to 4.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-20366 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An XSS issue was discovered in Ignite Realtime Openfire 4.4.4 via isTrustStore to Manage Store Contents.
O3 Security · Impact-Aware SCA

Is CVE-2019-20366 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-20366: parent XSS — Fixed in 4.5.0