CVE-2019-19687 is a high-severity (CVSS 8.8) CWE-522 vulnerability in keystone. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for keystone — see the affected versions and patch details below.
OpenStack Keystone Credential Leakage
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
keystone🐍keystoneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
OpenStack Keystone 15.0.0 and 16.0.0 is affected by Data Leakage in the list credentials API. Any user with a role on a project is able to list any credentials with the /v3/credentials API when enforce_scope is false. Users with a role on a project are able to view any other users' credentials, which could (for example) leak sign-on information for Time-based One Time Passwords (TOTP). Deployments with enforce_scope set to false are affected. (There will be a slight performance impact for the list credentials API once this issue is fixed.)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | keystone | ≥ 15.0.0&&< 15.0.1 | 15.0.1pip install --upgrade 'keystone==15.0.1' |
| 🐍PyPI | keystone | ≥ 16.0.0&&< 16.0.1 | 16.0.1pip install --upgrade 'keystone==16.0.1' |
Affected Products
keystoneopenstackResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keystone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update keystone to 15.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-19687 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
To mitigate this issue, set the [oslo_policy] enforce_scope option to 'true' in the keystone.conf file.Source: Red Hat security advisory for CVE-2019-19687 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 15.0 (Stein) | openstack-keystone-1:15.0.1-0.20190720060412.5f27c4b.1.el8ost | RHSA-2019:4358 |
| Red Hat OpenStack Platform 16.0 (Train) | openstack-keystone-1:16.0.1-0.20191210095025.bd3f637.el8ost | RHEA-2020:0283 |
Frequently Asked Questions
Is CVE-2019-19687 in your dependencies?
Find it across PyPI, including transitive dependencies.