CVE-2019-17195 — nimbus-jose-jwt
CRITICALCVE-2019-17195 is a critical-severity (CVSS 9.8) CWE-755 vulnerability in com.nimbusds:nimbus-jose-jwt. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for com.nimbusds:nimbus-jose-jwt — see the affected versions and patch details below.
Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.nimbusds:nimbus-jose-jwtReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Connect2id Nimbus JOSE+JWT before v7.9 can throw various uncaught exceptions while parsing a JWT, which could result in an application crash (potential information disclosure) or a potential authentication bypass.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.nimbusds:nimbus-jose-jwt | all versions | 7.9com.nimbusds:nimbus-jose-jwt:7.9 |
Affected Products
hadoopapachenimbus jose\+jwtconnect2idcommunications cloud native core security edge protection proxyoraclecommunications pricing design centeroracledata integratororacleenterprise manager base platformoracleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.nimbusds:nimbus-jose-jwt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.nimbusds:nimbus-jose-jwt to 7.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-17195 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
In Red Hat Virtualization 4.2, nimbus-jose-jwt was bundled in the rhvm-dependencies package. In Red Hat Virtualization 4.3, nimbus-jose-jwt was made available as a separate package and no longer bundled in rhvm-dependencies. Thus, rhvm-dependencies only contained this vulnerability in the 4.2 EUS stream, the 4.3…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Virtualization 4 for Red Hat Enterprise Linux 7 | apache-commons-beanutils-0:1.8.3-15.el7_7 | RHSA-2020:1308 |
Frequently Asked Questions
Is CVE-2019-17195 in your dependencies?
Find it across Maven, including transitive dependencies.