NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2017-12974 — nimbus-jose-jwt

HIGH

CVE-2017-12974 is a high-severity (CVSS 7.5) CWE-347 vulnerability in com.nimbusds:nimbus-jose-jwt. A fix is available for com.nimbusds:nimbus-jose-jwt — see the affected versions and patch details below.

Improper Verification of Cryptographic Signature in Nimbus JOSE+JWT

Also known asGHSA-pfv2-37f7-9m6w
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.59%1.17%1.76%0.1%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.nimbusds:nimbus-jose-jwt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Nimbus JOSE+JWT before 4.36 proceeds with ECKey construction without ensuring that the public x and y coordinates are on the specified curve, which allows attackers to conduct an Invalid Curve Attack in environments where the JCE provider lacks the applicable curve validation.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.nimbusds:nimbus-jose-jwtall versions4.36com.nimbusds:nimbus-jose-jwt:4.36

Affected Products

1 product · 123 configurations
Application
nimbus jose\+jwtconnect2id
123 versions
1.01.11.21.31.41.51.61.71.81.91.9.11.10

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.nimbusds:nimbus-jose-jwt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.nimbusds:nimbus-jose-jwt to 4.36 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-12974 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Nimbus JOSE+JWT before 4.36 proceeds with ECKey construction without ensuring that the public x and y coordinates are on the specified curve, which allows attackers to conduct an Invalid Curve Attack in environments where the JCE provider lacks the applicable curve validation.
O3 Security · Impact-Aware SCA

Is CVE-2017-12974 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-12974: nimbus-jose-jwt — Fixed in 4.36