NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2019-15532 — cyberchef

MEDIUMFix: gchq/CyberChef@01f0625

CVE-2019-15532 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in cyberchef. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for cyberchef — see the affected versions and patch details below.

Cross-Site Scripting in cyberchef

Also known asGHSA-jp6r-xcjj-5h7r
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.60%1.21%1.81%0.5%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
cyberchefnpm
2Kdownloads / week

Description

Versions of cyberchef prior to 8.31.3 are vulnerable to Cross-Site Scripting. In Text Encoding Brute Force the table rows are created by concatenating the value variable unsanitized in the HTML code. If this variable is controlled by user input it allows attackers to execute arbitrary JavaScript in a victim's browser.

Recommendation

Upgrade to version 8.31.3 or later.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmcyberchefall versions8.31.3npm install cyberchef@8.31.3

Affected Products

1 product · 1 configurations
Application
cyberchefgchq
< 8.31.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cyberchef, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cyberchef to 8.31.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-15532 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Versions of `cyberchef` prior to 8.31.3 are vulnerable to Cross-Site Scripting. In `Text Encoding Brute Force` the table rows are created by concatenating the `value` variable unsanitized in the HTML code. If this variable is controlled by user input it allows attackers to execute arbitrary JavaScript in a victim's browser. ## Recommendation Upgrade to version 8.31.3 or later.
O3 Security · Impact-Aware SCA

Is CVE-2019-15532 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2019-15532: cyberchef XSS — Fixed in 8.31.3