NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2026-42615 — cyberchef

HIGHFix: gchq/CyberChef@9641ae0

CVE-2026-42615 is a high-severity (CVSS 7.2) Cross-site Scripting (XSS) vulnerability in cyberchef. A fix is available for cyberchef — see the affected versions and patch details below.

CyberChef has a Cross-site Scripting issue

Also known asGHSA-h4hv-92pp-pcjg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-42615.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk-0.07%
Lower risk than most CVEs22th percentile — riskier than 22% of all scored CVEsHighest risk
0.00%0.29%0.58%0.87%0.0%0.3%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
cyberchefnpm
3Kdownloads / week

Description

GCHQ CyberChef before 11.0.0 allows XSS via Show Base64 offsets, as demonstrated by the /#recipe=Show_Base64_offsets('%3Cscript substring.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmcyberchefall versions11.0.0npm install cyberchef@11.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cyberchef, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cyberchef to 11.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-42615 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

GCHQ CyberChef before 11.0.0 allows XSS via Show Base64 offsets, as demonstrated by the /#recipe=Show_Base64_offsets('%3Cscript substring.
O3 Security · Impact-Aware SCA

Is CVE-2026-42615 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-42615: cyberchef XSS — Fixed in 11.0.0