NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2019-11255 — external-provisioner

MEDIUM

CVE-2019-11255 is a medium-severity (CVSS 6.5) Improper Input Validation vulnerability in github.com/kubernetes-csi/external-provisioner. A fix is available for github.com/kubernetes-csi/external-provisioner — see the affected versions and patch details below.

Kubernetes CSI Sidecar Containers Can Allow Unauthorized Data Access

Also known asGHSA-f4w6-3rh6-6q4q
Published
Updated
Affected
10 pkgs
Patched
6 / 10
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk+0.05%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.30%1.04%1.78%2.51%0.9%2.0%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

10 pkgs affected
🐹github.com/kubernetes-csi/external-provisioner🐹github.com/kubernetes-csi/external-provisioner🐹github.com/kubernetes-csi/external-provisioner🐹github.com/kubernetes-csi/external-provisioner🐹github.com/kubernetes-csi/external-provisioner🐹github.com/kubernetes-csi/external-snapshotter/v6🐹github.com/kubernetes-csi/external-snapshotter/v6🐹github.com/kubernetes-csi/external-snapshotter/v6+2 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Improper input validation in Kubernetes CSI sidecar containers for external-provisioner (<v0.4.3, <v1.0.2, v1.1, <v1.2.2, <v1.3.1), external-snapshotter (<v0.4.2, <v1.0.2, v1.1, <1.2.2), and external-resizer (v0.1, v0.2) could result in unauthorized PersistentVolume data access or volume mutation during snapshot, restore from snapshot, cloning and resizing operations.

Affected Packages

10 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/kubernetes-csi/external-provisionerall versions0.4.3go get github.com/kubernetes-csi/external-provisioner@v0.4.3
🐹Gogithub.com/kubernetes-csi/external-provisioner≥ 1.0.0&&< 1.0.21.0.2go get github.com/kubernetes-csi/external-provisioner@v1.0.2
🐹Gogithub.com/kubernetes-csi/external-provisionerall versionsNo fix
🐹Gogithub.com/kubernetes-csi/external-provisioner≥ 1.2.0&&< 1.2.21.2.2go get github.com/kubernetes-csi/external-provisioner@v1.2.2
🐹Gogithub.com/kubernetes-csi/external-provisioner≥ 1.3.0&&< 1.3.11.3.1go get github.com/kubernetes-csi/external-provisioner@v1.3.1
🐹Gogithub.com/kubernetes-csi/external-snapshotter/v6≥ 1.0.0&&< 1.0.21.0.2go get github.com/kubernetes-csi/external-snapshotter/v6@v1.0.2

Affected Products

4 products · 11 configurations
Application
external-provisionerkubernetes
≥ 1.1.0 && ≤ 1.2.1
1 version
1.3.0
Application
external-resizerkubernetes
≥ 0.1.0 && ≤ 0.2.0
range
Application
external-snapshotterkubernetes
≥ 1.1.0 && ≤ 1.2.1
range
Application
openshift container platformredhat
3 versions
3.114.14.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/kubernetes-csi/external-provisioner, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/kubernetes-csi/external-provisioner to 0.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-11255 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

OpenShift Container Storage Interface (CSI) is a Technology Preview (TP) feature in OpenShift Container Platform before version 4.2. https://access.redhat.com/support/offerings/techpreview

ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11openshift-external-storage-0:0.0.2-10.gitd3c94f0.el7RHSA-2019:4054
Red Hat OpenShift Container Platform 4.1openshift-external-storage-0:0.0.2-11.gitd3c94f0.el7RHSA-2019:4225
Red Hat OpenShift Container Platform 4.2openshift-external-storage-0:0.0.2-11.gitd3c94f0.el7RHSA-2019:4096
Red Hat OpenShift Container Platform 4.2openshift4/ose-csi-external-provisioner-rhel7:v4.2.10-201912022352RHSA-2019:4099

Frequently Asked Questions

Improper input validation in Kubernetes CSI sidecar containers for external-provisioner (<v0.4.3, <v1.0.2, v1.1, <v1.2.2, <v1.3.1), external-snapshotter (<v0.4.2, <v1.0.2, v1.1, <1.2.2), and external-resizer (v0.1, v0.2) could result in unauthorized PersistentVolume data access or volume mutation during snapshot, restore from snapshot, cloning and resizing operations.
O3 Security · Impact-Aware SCA

Is CVE-2019-11255 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2019-11255: external-provisioner — Fixed in 0.4.3