CVE-2019-10247 — jetty-server
MEDIUMCVE-2019-10247 is a medium-severity (CVSS 5.3) CWE-213 vulnerability in org.eclipse.jetty:jetty-server. A fix is available for org.eclipse.jetty:jetty-server — see the affected versions and patch details below.
Installation information leak in Eclipse Jetty
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.eclipse.jetty:jetty-server☕org.eclipse.jetty:jetty-server☕org.eclipse.jetty:jetty-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Eclipse Jetty version 7.x, 8.x, 9.2.27 and older, 9.3.26 and older, and 9.4.16 and older, the server running on any OS and Jetty version combination will reveal the configured fully qualified directory base resource location on the output of the 404 error for not finding a Context that matches the requested path. The default server behavior on jetty-distribution and jetty-home will include at the end of the Handler tree a DefaultHandler, which is responsible for reporting this 404 error, it presents the various configured contexts as HTML for users to click through to. This produced HTML includes output that contains the configured fully qualified directory base resource location for each context.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 7.0.0&&< 9.2.28.v20190418 | 9.2.28.v20190418org.eclipse.jetty:jetty-server:9.2.28.v20190418 |
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 9.3.0&&< 9.3.27.v20190418 | 9.3.27.v20190418org.eclipse.jetty:jetty-server:9.3.27.v20190418 |
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 9.4.0&&< 9.4.17.v20190418 | 9.4.17.v20190418org.eclipse.jetty:jetty-server:9.4.17.v20190418 |
Affected Products
debian linuxdebianjettyeclipseelementnetapponcommand system managernetappsnap creator frameworknetappsnapcenternetappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.jetty:jetty-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.eclipse.jetty:jetty-server to 9.2.28.v20190418 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10247 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue affects the versions of jetty which is embedded in the nutch package as shipped with Red Hat Satellite 5. The jetty server is not exposed, as such exploitation is difficult, Red Hat Product Security has rated this issue as having security impact of Low in the context of Red Hat Satellite 5. A future update…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ | jetty | RHSA-2020:0922 |
| Red Hat AMQ 7.4.3 | jetty | RHSA-2020:1445 |
| Red Hat Fuse 7.6.0 | see advisory | RHSA-2020:0983 |
Frequently Asked Questions
Is CVE-2019-10247 in your dependencies?
Find it across Maven, including transitive dependencies.