NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2019-1020005 — invenio-communities

MEDIUMFix: inveniosoftware/invenio-communities@505da72

CVE-2019-1020005 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in invenio-communities. A fix is available for invenio-communities — see the affected versions and patch details below.

Cross-site Scripting in invenio-communities

Also known asGHSA-mfv8-q39f-mgfgPYSEC-2019-25
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.39%0.79%1.18%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍invenio-communities

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-Site Scripting (XSS) vulnerability in Jinja templates

Impact

A Cross-Site Scripting (XSS) vulnerability was discovered in two Jinja templates in the Invenio-Communities module. The vulnerability allows a user to create a new community and include script element tags inside the description and page fields.

Patches

The problem has been patched in v1.0.0a20.

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIinvenio-communitiesall versions1.0.0a20pip install --upgrade 'invenio-communities==1.0.0a20'

Affected Products

1 product · 19 configurations
Application
invenio-communitiesinveniosoftware
1 version
1.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for invenio-communities, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update invenio-communities to 1.0.0a20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-1020005 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

## Cross-Site Scripting (XSS) vulnerability in Jinja templates ### Impact A Cross-Site Scripting (XSS) vulnerability was discovered in two Jinja templates in the Invenio-Communities module. The vulnerability allows a user to create a new community and include script element tags inside the description and page fields. ### Patches The problem has been patched in v1.0.0a20. ### For more information If you have any questions or comments about this advisory: * Email us at [[email protected]](mailto:[email protected])
O3 Security · Impact-Aware SCA

Is CVE-2019-1020005 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-1020005: invenio XSS — Fixed in 1.0.0a20