Invenio-Communities has a Cross-Site Scripting (XSS) vulnerability in React componentsGHSA-hjx6-f647-mvf9
MEDIUMFix: inveniosoftware/invenio-communities@4424dd5GHSA-hjx6-f647-mvf9 is a medium-severity (CVSS 6.3) vulnerability in invenio-communities. A fix is available for invenio-communities — see the affected versions and patch details below.
Real-World Exposure
invenio-communities🐍invenio-communities🐍invenio-communitiesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
We have identified a Cross-Site Scripting (XSS) vulnerability within certain React components related to community members in the Invenio-Communities module. This vulnerability enables a user to inject a script tag into the Affiliations field during the account registration process. The malicious script is executed when the user creates a new community and is listed as a public member.
The script is triggered whenever any user visits the Members section of any community that includes the compromised user. This can potentially allow the attacker to access personal information, such as cookies, of the visiting user.
Patches
The problem has been patched in v7.8.0. Patches also have been backported in versions v4.2.2 and v2.8.11.
Credits
Thanks to Twitter.com/AliGoodLuck11 for reporting the vulnerability with a detailed description on how to reproduce it!
For more information
If you have any questions or comments about this advisory:
Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | invenio-communities | ≥ 5.0.0&&< 7.8.0 | 7.8.0pip install --upgrade 'invenio-communities==7.8.0' |
| 🐍PyPI | invenio-communities | ≥ 3.0.0&&< 4.2.2 | 4.2.2pip install --upgrade 'invenio-communities==4.2.2' |
| 🐍PyPI | invenio-communities | all versions | 2.8.11pip install --upgrade 'invenio-communities==2.8.11' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for invenio-communities, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update invenio-communities to 7.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hjx6-f647-mvf9 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-hjx6-f647-mvf9 in your dependencies?
Find it across PyPI, including transitive dependencies.