NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2019-1003041 — workflow-cps

CRITICALFix: jenkinsci/workflow-cps-plugin@2e5a67f

CVE-2019-1003041 is a critical-severity (CVSS 9.8) CWE-470 vulnerability in org.jenkins-ci.plugins.workflow:workflow-cps. A fix is available for org.jenkins-ci.plugins.workflow:workflow-cps — see the affected versions and patch details below.

Sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin

Also known asGHSA-x74x-qf5j-35jh
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
1.30%2.18%3.05%3.93%1.8%3.4%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins.workflow:workflow-cps

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows attackers to invoke arbitrary constructors in sandboxed scripts.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins.workflow:workflow-cpsall versions2.65org.jenkins-ci.plugins.workflow:workflow-cps:2.65

Affected Products

2 products · 2 configurations
Application
pipeline\jenkins
≤ 2.64
1 version
_groovy
Application
openshift container platformredhat
1 version
3.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins.workflow:workflow-cps, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins.workflow:workflow-cps to 2.65 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-1003041 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11jenkins-2-plugins-0:3.11.1553788831-1.el7RHSA-2019:1423

Frequently Asked Questions

A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows attackers to invoke arbitrary constructors in sandboxed scripts.
O3 Security · Impact-Aware SCA

Is CVE-2019-1003041 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-1003041: workflow-cps — Fixed in 2.65