CVE-2019-0201 — zookeeper
MEDIUMCVE-2019-0201 is a medium-severity (CVSS 5.9) CWE-862 vulnerability in org.apache.zookeeper:zookeeper. A fix is available for org.apache.zookeeper:zookeeper — see the affected versions and patch details below.
Access control bypass in Apache ZooKeeper
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.zookeeper:zookeeper☕org.apache.zookeeper:zookeeperReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
An issue is present in Apache ZooKeeper 1.0.0 to 3.4.13 and 3.5.0-alpha to 3.5.4-beta. ZooKeeper’s getACL() command doesn’t check any permission when retrieves the ACLs of the requested node and returns all information contained in the ACL Id field as plaintext string. DigestAuthenticationProvider overloads the Id field with the hash value that is used for user authentication. As a consequence, if Digest Authentication is in use, the unsalted hash value will be disclosed by getACL() request for unauthenticated or unprivileged users.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.zookeeper:zookeeper | ≥ 1.0.0&&< 3.4.14 | 3.4.14org.apache.zookeeper:zookeeper:3.4.14 |
| ☕Maven | org.apache.zookeeper:zookeeper | ≥ 3.5.0&&< 3.5.5 | 3.5.5org.apache.zookeeper:zookeeper:3.5.5 |
Affected Products
activemqapachedrillapachezookeeperapachedebian linuxdebianelement softwarenetapphci bootstrap osnetappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.zookeeper:zookeeper, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.zookeeper:zookeeper to 3.4.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-0201 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Use an authentication method other than Digest (e.g. Kerberos) or upgrade to zookeeper 3.4.14 or later (3.5.5 or later if on the 3.5 branch). [https://zookeeper.apache.org/security.html#CVE-2019-0201]Source: Red Hat security advisory for CVE-2019-0201 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Fuse 6.3 | zookeeper | RHSA-2019:4352 |
| Red Hat Fuse 7.5.0 | zookeeper | RHSA-2019:3892 |
| Red Hat JBoss Data Virtualization 6.4.8 | zookeeper | RHSA-2019:3140 |
Frequently Asked Questions
Is CVE-2019-0201 in your dependencies?
Find it across Maven, including transitive dependencies.