CVE-2018-8012 — zookeeper
HIGHCVE-2018-8012 is a high-severity (CVSS 7.5) CWE-862 vulnerability in org.apache.zookeeper:zookeeper. A fix is available for org.apache.zookeeper:zookeeper — see the affected versions and patch details below.
Missing Authorization in Apache ZooKeeper
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.zookeeper:zookeeper☕org.apache.zookeeper:zookeeperReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
No authentication/authorization is enforced when a server attempts to join a quorum in Apache ZooKeeper before 3.4.10, and 3.5.0-alpha through 3.5.3-beta. As a result an arbitrary end point could join the cluster and begin propagating counterfeit changes to the leader.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.zookeeper:zookeeper | all versions | 3.4.10org.apache.zookeeper:zookeeper:3.4.10 |
| ☕Maven | org.apache.zookeeper:zookeeper | ≥ 3.5.0-alpha&&< 3.5.4-beta | 3.5.4-betaorg.apache.zookeeper:zookeeper:3.5.4-beta |
Affected Products
zookeeperapachedebian linuxdebiangoldengate stream analyticsoracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.zookeeper:zookeeper, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.zookeeper:zookeeper to 3.4.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-8012 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2018-8012 in your dependencies?
Find it across Maven, including transitive dependencies.