NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2017-5637 — zookeeper

HIGH

CVE-2017-5637 is a high-severity (CVSS 7.5) Missing Authentication vulnerability in org.apache.zookeeper:zookeeper. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.zookeeper:zookeeper — see the affected versions and patch details below.

Uncontrolled Resource Consumption in Apache ZooKeeper

Also known asGHSA-7cwj-j333-x7f7
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
73.1%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
0.58%30.6%60.5%90.5%17.4%73.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.zookeeper:zookeeper☕org.apache.zookeeper:zookeeper

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Two four letter word commands "wchp/wchc" are CPU intensive and could cause spike of CPU utilization on Apache ZooKeeper server if abused, which leads to the server unable to serve legitimate client requests. Apache ZooKeeper thru version 3.4.9 and 3.5.2 suffer from this issue, fixed in 3.4.10, 3.5.3, and later.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.zookeeper:zookeeper≥ 3.4.0&&< 3.4.103.4.10org.apache.zookeeper:zookeeper:3.4.10
☕Mavenorg.apache.zookeeper:zookeeper≥ 3.5.0&&< 3.5.33.5.3org.apache.zookeeper:zookeeper:3.5.3

Affected Products

2 products · 14 configurations
Application
zookeeperapache
13 versions
3.4.03.4.13.4.23.4.33.4.43.4.53.4.63.4.73.4.83.4.93.5.03.5.1
OS
debian linuxdebian
1 version
8.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-42294dosmultiple

Zookeeper 3.5.2 Client - Denial of Service

by Brandon Dennis · Jul 2, 2017

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.zookeeper:zookeeper, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.zookeeper:zookeeper to 3.4.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-5637 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat JBoss BPMS 6.4zookeeperRHSA-2017:3355
Red Hat JBoss BRMS 6.4zookeeperRHSA-2017:3354
Red Hat JBoss Data Virtualization 6.3zookeeperRHSA-2017:2477

Frequently Asked Questions

Two four letter word commands "wchp/wchc" are CPU intensive and could cause spike of CPU utilization on Apache ZooKeeper server if abused, which leads to the server unable to serve legitimate client requests. Apache ZooKeeper thru version 3.4.9 and 3.5.2 suffer from this issue, fixed in 3.4.10, 3.5.3, and later.
O3 Security · Impact-Aware SCA

Is CVE-2017-5637 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-5637: zookeeper — Fixed in 3.4.10