CVE-2018-19800 is a critical-severity (CVSS 9.8) Buffer Overflow vulnerability in aubio. A fix is available for aubio — see the affected versions and patch details below.
aubio Buffer Overflow vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
aubioReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
aubio v0.4.0 to v0.4.8 has a Buffer Overflow in new_aubio_tempo.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | aubio | ≥ 0.4.0&&< 0.4.9 | 0.4.9pip install --upgrade 'aubio==0.4.9' |
Affected Products
aubioaubioDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aubio, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update aubio to 0.4.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-19800 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is CVE-2018-19800 in your dependencies?
Find it across PyPI, including transitive dependencies.